RegisterRegister
Log in to check your private messagesLog in to check your private messages
Log inLog in
FAQ  -  SEARCH  -  MEMBERS  -  FAVORITES  -  PROFILE
New Mac Mini 2014 Low Buffer Rate Maxes CPU

 
Post new topic   Reply to topic   printer-friendly view    Tape Op Message Board Forum Index -> Computer World
View previous topic :: View next topic  
Author Message
angopop
pluggin' in mics


Joined: 03 Jun 2003
Posts: 33
Location: Los Angeles

PostPosted: Sat Mar 19, 2016 2:14 pm    Post subject: New Mac Mini 2014 Low Buffer Rate Maxes CPU Reply with quote

New Mac Mini 2014 Low Buffer Rate Maxes CPU



Recently bought a new Mac Mini (late 2014 2.6 GHz Intel Core i5 w 16 GB RAM) to run PT 12 with Apollo 8, as I needed to upgrade from 2011 Mac Mini Server (mid 2011, 2 GHz Intel Core i7 with 8 GB RAM) running Digi 002. That old Mac couldnít run the Apollo unless I upgraded the Mac OS, but I didnít want to lose that system, so I bought the new Mac Mini with the idea of keeping the old one as a back up and to access old sessions.

Iím finding now on the new Mac with using guitar software like Amplitube 4 and Scuffham, that I am quickly maxing out my CPU usage unless I set buffer size to 128, which is too much latency. I was able to run Amplitube 3 on the old Mac at 32 samples buffer, and I could switch to 64 if I needed to.

Iíve tried setting both software to Economy mode. Iíve tried not viewing gain reduction in track meters and changed from waveform view to blocks, Iíve tried setting PT 12 memory to high and low cache sizeÖ and still maxing out CPU usage, even though the PT system usage bars show 4 processors.

Perhaps this Mac Mini is just not powerful enough. Since my old Mac Mini server has two internal hard drives, I will try Carbon Copy clone my new Mac to the second drive of my old one, just a thought.

Is there anything Iím missing out on setting my Mac or PTools? Any ideas?
Back to top
View user's profile Send private message Send e-mail
kslight
dead but not forgotten


Joined: 13 Oct 2009
Posts: 2172

PostPosted: Sat Mar 19, 2016 3:02 pm    Post subject: Re: New Mac Mini 2014 Low Buffer Rate Maxes CPU Reply with quote

I'm kind of surprised that with a buffer set at 128 you are getting too much latency?
What sample rate are you running at?


I don't have Amplitube 4, but I have version 3 (refuse to send IK any more money however). I noticed that Amplitube 4's system requirements jumped quite a bit so that may be part of the problem.

Also best I can tell your new Mac Mini is a dual core i5, and the i5 to my knowledge does not support hyperthreading as the i7 does, so that could also account for a significant performance difference.


Have you disabled all other CPU hogs, such as WiFi?
Back to top
View user's profile Send private message
angopop
pluggin' in mics


Joined: 03 Jun 2003
Posts: 33
Location: Los Angeles

PostPosted: Sat Apr 09, 2016 12:55 pm    Post subject: Re: New Mac Mini 2014 Low Buffer Rate Maxes CPU Reply with quote

Thanks,

I'm running sessions at 44.1k/24 bit.

I find that if I have run any other software, when I restart my mac, I can just about run a simple session, or a complicated session if I freeze any tracks that have inserts. That is one workaround, but doesn't necessarily make me feel good about my rig.

I do have wifi disabled, but any suggestions for other software that may be hogging CPU power (I haven't found anything obvious in Activity Monitor....
Back to top
View user's profile Send private message Send e-mail
Nick Sevilla
speech impediment


Joined: 03 Mar 2008
Posts: 4453
Location: Los Angeles California USA

PostPosted: Mon Apr 11, 2016 4:27 pm    Post subject: Re: New Mac Mini 2014 Low Buffer Rate Maxes CPU Reply with quote

Question:

How many CPUs is this machine?

Whatever number they are, in Pro Tools preferences,
you MUST set it to one LESS than what you have.

This way you have ONE CPU not being hogged by the Pro Tools DAE engine.

Try this and see if it helps any.

Also, if possible, turn off BLUETOOTH. And most if not all network sharing things, except maybe for "files". That is how I have both my macs set up. they run fine.
_________________
The Song. Nothing else really matters.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger
angopop
pluggin' in mics


Joined: 03 Jun 2003
Posts: 33
Location: Los Angeles

PostPosted: Mon Apr 11, 2016 11:45 pm    Post subject: Re: New Mac Mini 2014 Low Buffer Rate Maxes CPU Reply with quote

It is a dual core MacMini, the middle version currently available, which is a 2.6Ghz i5.

I'm running PT12, so there is now no way to set the number of CPU's used by PTools, it is set automatically.

I will turn off BlueTooth, see if that helps....Thanks.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    Tape Op Message Board Forum Index -> Computer World All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum